1DESCRIPTION = "A C-language AMQP client library for use with v2.0+ of the RabbitMQ broker"
2HOMEPAGE = "https://github.com/alanxz/rabbitmq-c"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=7e12f6e40e662e039e2f02b4893011ec"
4LICENSE = "MIT"
5
6SRC_URI = "git://github.com/alanxz/rabbitmq-c.git;branch=master;protocol=https \
7           file://CVE-2023-35789.patch \
8"
9# v0.13.0-master
10SRCREV = "974d71adceae6d742ae20a4c880d99c131f1460a"
11
12S = "${WORKDIR}/git"
13
14DEPENDS = "popt openssl"
15
16EXTRA_OECMAKE = "-DBUILD_EXAMPLES=OFF -DBUILD_TOOLS=ON -DBUILD_TOOLS_DOCS=OFF -DBUILD_API_DOCS=OFF"
17
18inherit cmake pkgconfig
19
20PACKAGE_BEFORE_PN += "${PN}-tools"
21FILES:${PN}-tools = "${bindir}"
22