1DESCRIPTION = "The Openobex project is an open source implementation of the \
2Object Exchange (OBEX) protocol."
3HOMEPAGE = "http://openobex.triq.net"
4SECTION = "libs"
5LICENSE = "GPL-2.0-only & LGPL-2.1-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
7                    file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
8"
9
10DEPENDS = "virtual/libusb0"
11DEPENDS:append:class-target = " bluez5"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${PV}/${BP}-Source.tar.gz \
14"
15SRC_URI[sha256sum] = "158860aaea52f0fce0c8e4b64550daaae06df2689e05834697b7e8c7d73dd4fc"
16
17UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/openobex/files/openobex/"
18UPSTREAM_CHECK_REGEX = "${BPN}/(?P<pver>\d+(\.\d+)+)"
19
20S = "${WORKDIR}/${BP}-Source"
21
22inherit cmake pkgconfig
23
24EXTRA_OECONF = " -DCMAKE_SKIP_RPATH=ON "
25EXTRA_OECMAKE += "-DBUILD_DOCUMENTATION=OFF"
26
27ASNEEDED = ""
28
29do_install:append () {
30    rmdir ${D}${bindir}
31}
32
33PACKAGES =+ "openobex-apps"
34FILES:${PN}-apps = "${bindir}/*"
35FILES:${PN} += "${libdir}/lib*.so.*"
36FILES:${PN}-dev += "${bindir}/openobex-config"
37DEBIAN_NOAUTONAME:${PN}-apps = "1"
38
39BBCLASSEXTEND = "native"
40