1DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
9SRC_URI = "git://github.com/rakshasa/libtorrent;branch=master;protocol=https \
10           file://don-t-run-code-while-configuring-package.patch \
11           "
12SRCREV = "756f70010779927dc0691e1e722ed433d5d295e1"
13
14CVE_CHECK_IGNORE += "\
15    CVE-2009-1760 \
16"
17
18PV = "0.13.8"
19
20S = "${WORKDIR}/git"
21
22PACKAGECONFIG ??= "instrumentation"
23
24PACKAGECONFIG:remove:mipsarch = "instrumentation"
25PACKAGECONFIG:remove:powerpc = "instrumentation"
26PACKAGECONFIG:remove:riscv32 = "instrumentation"
27
28PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
29
30inherit autotools pkgconfig
31
32EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
33
34do_configure:prepend() {
35    (cd ${S}; ./autogen.sh; cd -)
36}
37