1DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
9SRC_URI = "git://github.com/rakshasa/libtorrent;branch=master;protocol=https"
10SRCREV = "e60f222241319aaae482789517ad00ae9344bd13"
11
12CVE_CHECK_IGNORE += "\
13    CVE-2009-1760 \
14"
15
16PV = "0.13.8+git${SRCPV}"
17
18S = "${WORKDIR}/git"
19
20
21PACKAGECONFIG ??= "instrumentation aligned"
22
23PACKAGECONFIG:remove:mipsarch = "instrumentation"
24PACKAGECONFIG:remove:powerpc = "instrumentation"
25PACKAGECONFIG:remove:riscv32 = "instrumentation"
26
27PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
28PACKAGECONFIG[aligned] = "--enable-aligned,--disable-aligned,"
29
30inherit autotools pkgconfig
31
32EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
33