1DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
9PV = "0.13.8+git"
10
11SRC_URI = "git://github.com/rakshasa/libtorrent;branch=master;protocol=https"
12SRCREV = "e60f222241319aaae482789517ad00ae9344bd13"
13
14UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
15
16CVE_STATUS[CVE-2009-1760] = "backported-patch: patched in our product"
17
18S = "${WORKDIR}/git"
19
20PACKAGECONFIG ??= "instrumentation aligned"
21
22PACKAGECONFIG:remove:mipsarch = "instrumentation"
23PACKAGECONFIG:remove:powerpc = "instrumentation"
24PACKAGECONFIG:remove:riscv32 = "instrumentation"
25
26PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
27PACKAGECONFIG[aligned] = "--enable-aligned,--disable-aligned,"
28
29inherit autotools pkgconfig
30
31EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
32