1DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
9PV = "0.13.8+git"
10
11SRC_URI = "git://github.com/rakshasa/libtorrent;branch=master;protocol=https"
12SRCREV = "e60f222241319aaae482789517ad00ae9344bd13"
13
14UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
15
16S = "${WORKDIR}/git"
17
18PACKAGECONFIG ??= "instrumentation aligned"
19
20PACKAGECONFIG:remove:mipsarch = "instrumentation"
21PACKAGECONFIG:remove:powerpc = "instrumentation"
22PACKAGECONFIG:remove:riscv32 = "instrumentation"
23
24PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
25PACKAGECONFIG[aligned] = "--enable-aligned,--disable-aligned,"
26
27inherit autotools pkgconfig
28
29EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
30