1DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
9SRC_URI = "git://github.com/rakshasa/libtorrent;branch=master;protocol=https \
10           file://don-t-run-code-while-configuring-package.patch \
11           "
12SRCREV = "756f70010779927dc0691e1e722ed433d5d295e1"
13
14PV = "0.13.8"
15
16S = "${WORKDIR}/git"
17
18PACKAGECONFIG ??= "instrumentation"
19
20PACKAGECONFIG:remove:mipsarch = "instrumentation"
21PACKAGECONFIG:remove:powerpc = "instrumentation"
22PACKAGECONFIG:remove:riscv32 = "instrumentation"
23
24PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
25
26inherit autotools pkgconfig
27
28EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
29
30do_configure:prepend() {
31    (cd ${S}; ./autogen.sh; cd -)
32}
33