1# TODO: include debian's mtp-tools man page (needs xsltproc-native and
2# docbook-xsl-native, or we pregenerate it), add support for doxygen
3# generation fully with -natives
4DESCRIPTION = "libmtp is an Initiator implementation of the Media Transfer \
5Protocol (MTP) in the form of a library suitable primarily for POSIX \
6compliant operating systems"
7SUMMARY = "libmtp is an Initiator implementation of the Media Transfer Protocol (MTP)"
8HOMEPAGE = "http://libmtp.sourceforge.net/"
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1 \
11                    file://src/ptp.c;beginline=3;endline=22;md5=80fd2d5904c4c1f5455d8f4bf515292f \
12                    file://examples/albums.c;beginline=5;endline=21;md5=84f4e55dfec49e898b7f68a828c15620 \
13                    "
14
15BBCLASSEXTEND = "native"
16
17DEPENDS = "libusb1 gettext-native"
18DEPENDS:append:class-target = " ${BPN}-native"
19
20SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
21SRC_URI:append:class-target = " file://0001-Use-native-mtp-hotplug.patch"
22SRC_URI[sha256sum] = "f4c1ceb3df020a6cb851110f620c14fe399518c494ed252039cbfb4e34335135"
23
24inherit autotools pkgconfig lib_package
25
26EXTRA_OECONF += " \
27    --disable-rpath \
28    --enable-largefile \
29    --with-udev=${nonarch_base_libdir}/udev \
30"
31
32PACKAGECONFIG ?= ""
33PACKAGECONFIG[doxygen] = "--enable-doxygen,--disable-doxygen,doxygen-native"
34PACKAGECONFIG[mtpz] = "--enable-mtpz,--disable-mtpz,libgcrypt"
35
36PACKAGES =+ "${BPN}-common ${BPN}-runtime"
37
38RDEPENDS:${BPN} += "libmtp-common"
39RRECOMMENDS:${BPN} += "libmtp-runtime ${PN}-bin"
40
41FILES:${BPN}-common = "${nonarch_base_libdir}/udev/rules.d/*"
42SUMMARY:${BPN}-common = "The udev rules file for MTP devices"
43
44FILES:${BPN}-runtime = "${nonarch_base_libdir}/udev/mtp-probe"
45RDEPENDS:${BPN}-runtime = "libmtp-common"
46SUMMARY:${BPN}-runtime = "mtp-probe, used for the MTP udev rules"
47DESCRIPTION:${BPN}-runtime = "This package provides mtp-probe, a program to probe newly connected device interfaces from userspace to determine if they are MTP devices, used for udev rules."
48