1SUMMARY = "ncurses IRC client"
2DESCRIPTION = "Irssi is an ncurses IRC client"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55fdc1113306167d6ea2561404ce02f8"
5
6DEPENDS = "glib-2.0 ncurses openssl"
7
8SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.xz"
9SRC_URI[sha256sum] = "72a951cb0ad622785a8962801f005a3a412736c7e7e3ce152f176287c52fe062"
10
11UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
12
13inherit autotools pkgconfig
14
15EXTRA_OECONF += "--with-textui \
16                 --with-proxy \
17                 --with-bot \
18                 --with-perl=no \
19                 --enable-true-color"
20
21FILES:${PN}-staticdev += "${libdir}/${BPN}/modules/*.a"
22