1DESCRIPTION = "Bluetooth library with attribute support"
2SECTION = "libs/network"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://CMakeLists.txt;beginline=1;endline=20;md5=8d5efeb9189b60866baff80ff791bf00"
6
7DEPENDS = "bluez5 glib-2.0"
8DEPENDS += "glib-2.0-native"
9
10PV = "0.2+git${SRCPV}"
11
12SRC_URI = "git://github.com/labapart/gattlib.git \
13           file://dbus-avoid-strange-chars-from-the-build-dir.patch \
14           file://0001-cmake-Use-GNUInstallDirs.patch \
15           "
16
17SRCBRANCH = "master"
18SRCREV = "5c7ee43bd70ee09a7170ddd55b9fdbdef69e9080"
19
20S = "${WORKDIR}/git"
21
22PACKAGECONFIG[examples] = "-DGATTLIB_BUILD_EXAMPLES=ON,-DGATTLIB_BUILD_EXAMPLES=OFF"
23
24# Set this to force use of DBus API if Bluez version is older than 5.42
25PACKAGECONFIG[force-dbus] = "-DGATTLIB_FORCE_DBUS=TRUE,-DGATTLIB_FORCE_DBUS=FALSE"
26
27EXTRA_OECMAKE += "-DGATTLIB_BUILD_DOCS=OFF"
28
29inherit pkgconfig cmake
30
31FILES_${PN} = "${libdir}/*"
32FILES_${PN}-dev = "${includedir}/*"
33