1SUMMARY = "Userspace helper for Linux kernel EDAC drivers"
2HOMEPAGE = "https://github.com/grondo/edac-utils"
3DESCRIPTION = "EDAC (Error Detection and Correction) is a set of Linux kernel \
4modules that handle reporting of hardware-related errors. Currently \
5these modules mainly handle detection of ECC memory errors for many \
6x86 and x86-64 chipsets and PCI bus parity errors."
7SECTION = "Applications/System"
8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11DEPENDS = " sysfsutils"
12
13SRCREV = "1c57818ecee186aa47af0342149577df5302c022"
14PV = "0.18+git"
15
16S = "${WORKDIR}/git"
17
18SRC_URI = "git://github.com/grondo/edac-utils;branch=master;protocol=https \
19    file://make-init-script-be-able-to-automatically-load-EDAC-.patch \
20    file://add-restart-to-initscript.patch \
21    file://edac.service \
22"
23
24inherit autotools-brokensep systemd
25
26do_configure:prepend () {
27    touch ${S}/ChangeLog
28    ${S}/bootstrap
29}
30
31RDEPENDS:${PN}:x86 = "dmidecode"
32RDEPENDS:${PN}:x86-64 = "dmidecode"
33RDEPENDS:${PN}:arm = "dmidecode"
34RDEPENDS:${PN}:aarch64 = "dmidecode"
35RDEPENDS:${PN}:powerpc = "dmidecode"
36RDEPENDS:${PN}:powerpc64 = "dmidecode"
37RDEPENDS:${PN}:powerpc64le = "dmidecode"
38RDEPENDS:${PN}:append = " \
39    perl \
40    perl-module-file-basename \
41    perl-module-file-find \
42    perl-module-getopt-long \
43    perl-module-posix \
44    perl-module-overload \
45    perl-module-overloading \
46    perl-module-file-glob \
47"
48
49do_install:append() {
50	install -d ${D}${systemd_unitdir}/system
51	install -m 644 ${WORKDIR}/edac.service ${D}/${systemd_unitdir}/system
52	sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}/${systemd_unitdir}/system/edac.service
53}
54
55SYSTEMD_SERVICE:${PN} = "edac.service"
56SYSTEMD_AUTO_ENABLE:${PN} = "disable"
57