1SUMMARY = "Threaded I/O tester"
2HOMEPAGE = "http://sourceforge.net/projects/tiobench/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
5
6PR = "r1"
7
8SRC_URI = "\
9    http://sourceforge.net/projects/tiobench/files/tiobench/${PV}/${BP}.tar.gz \
10    file://tiobench-makefile.patch \
11    file://avoid-glibc-clashes.patch \
12    file://0001-Drop-inline-of-crc32-function-to-fix-build-using-GCC.patch \
13    file://0001-Specify-printf-formats.patch \
14"
15SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128"
16SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc"
17
18EXTRA_OEMAKE = "PREFIX=${D}/usr"
19
20do_install() {
21    oe_runmake install
22}
23
24RDEPENDS_${PN} = "\
25    perl \
26    perl-module-exporter-heavy \
27    perl-module-getopt-long \
28    perl-module-overload \
29    perl-module-strict \
30"
31