1DESCRIPTION = "A simple memory benchmark program, which tries to measure the \
2peak bandwidth of sequential memory accesses and the latency of random memory \
3accesses. Bandwidth is measured by running different assembly code for the \
4aligned memory blocks and attempting different prefetch strategies"
5HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345"
8
9PV = "0.4.9+git"
10
11SRCREV = "a2cf6d7e382e3aea1eb39173174d9fa28cad15f3"
12SRC_URI = "git://github.com/ssvb/tinymembench.git;branch=master;protocol=https \
13           file://0001-asm-Delete-.func-.endfunc-directives.patch \
14           "
15
16S = "${WORKDIR}/git"
17
18TARGET_CC_ARCH += "${LDFLAGS}"
19
20do_install() {
21    install -d ${D}${bindir}
22    install -m755 tinymembench ${D}${bindir}/
23}
24
25# Fails to build with thumb-1 (qemuarm)
26#| {standard input}: Assembler messages:
27#| {standard input}:66: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
28#| {standard input}:69: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
29#| {standard input}:82: Error: selected processor does not support Thumb mode `mla r3,r4,r3,r5'
30#| {standard input}:82: Error: unshifted register required -- `and r8,r7,r3,lsr#16'
31ARM_INSTRUCTION_SET = "arm"
32#
33# Does not work for 64bit mips.
34#
35COMPATIBLE_HOST = "^(?!mips64).*"
36