1SUMMARY = "System performance benchmark"
2HOMEPAGE = "http://github.com/akopytov/sysbench"
3SECTION = "console/tests"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "libtool luajit concurrencykit"
8
9inherit autotools-brokensep pkgconfig
10
11# The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
12# Launchpad until the next release is available from Github.
13SRC_URI = "git://github.com/akopytov/sysbench.git;protocol=https;branch=master"
14SRCREV = "ebf1c90da05dea94648165e4f149abc20c979557"
15
16S = "${WORKDIR}/git"
17
18COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64).*-linux*"
19
20EXTRA_OECONF += "--enable-largefile --with-system-luajit --with-system-ck --without-gcc-arch --with-lib-prefix=no"
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio,"
23PACKAGECONFIG[mysql] = "--with-mysql \
24                        --with-mysql-includes=${STAGING_INCDIR}/mysql \
25                        --with-mysql-libs=${STAGING_LIBDIR}, \
26                        --without-mysql,mysql5"
27
28do_configure:prepend() {
29    touch ${S}/NEWS ${S}/AUTHORS
30}
31