1SUMMARY = "Phoronix Test Suite"
2DESCRIPTION = "The Phoronix Test Suite is designed to carry out both qualitative \
3and quantitative benchmarks in a clean, reproducible, and easy-to-use manner."
4LICENSE = "GPL-3.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6SECTION = "console/tests"
7
8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
9SRC_URI[sha256sum] = "1f2092d536c0a3193efc53e4a50f3cee65c0ef1a78d31e5404f1c663fff7b7f4"
10
11S = "${WORKDIR}/phoronix-test-suite"
12
13inherit systemd allarch mime mime-xdg
14
15do_install() {
16    DESTDIR=${D} ./install-sh ${exec_prefix}
17
18    if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
19        install -d ${D}/${systemd_unitdir}/system/
20        mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
21        rm -rf ${D}/usr/lib/
22    fi
23}
24
25# It is not advisable to enable these services by default since they can cause
26# continual target reboots if they encounter network problems.
27#
28SYSTEMD_AUTO_ENABLE = "disable"
29SYSTEMD_SERVICE:${PN} = "phoromatic-client.service phoromatic-server.service"
30
31RDEPENDS:${PN} += "bash python3-core php-cli util-linux-lscpu os-release lsb-release"
32
33FILES:${PN} += " \
34    ${datadir}/phoronix-test-suite \
35    ${datadir}/appdata/phoronix-test-suite.appdata.xml \
36    ${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
37    ${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
38    ${datadir}/mime/packages/openbenchmarking-mime.xml \
39    ${systemd_unitdir}/* \
40"
41