1SUMMARY = "OpenGL (ES) 2.0 benchmark"
2DESCRIPTION = "glmark2 is a benchmark for OpenGL (ES) 2.0. \
3It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0."
4HOMEPAGE = "https://launchpad.net/glmark2"
5BUGTRACKER = "https://bugs.launchpad.net/glmark2"
6
7LICENSE = "GPLv3+ & SGIv1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
9                    file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552"
10
11DEPENDS = "libpng jpeg udev"
12
13PV = "20190205+${SRCPV}"
14
15COMPATIBLE_HOST_rpi  = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '.*-linux*', 'null', d)}"
16
17SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https"
18SRCREV = "0c90dd48df43a6b0db1d9aabca6298240f4968f7"
19
20S = "${WORKDIR}/git"
21
22inherit waf pkgconfig distro_features_check
23
24REQUIRED_DISTRO_FEATURES += "opengl"
25
26PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl x11-gles2', '', d)} \
27                  ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \
28                  drm-gl drm-gles2"
29
30PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11"
31PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11"
32PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm virtual/libgbm"
33PACKAGECONFIG[drm-gles2] = ",,virtual/libgles2 libdrm virtual/libgbm"
34PACKAGECONFIG[wayland-gl] = ",,virtual/libgl wayland"
35PACKAGECONFIG[wayland-gles2] = ",,virtual/libgles2 wayland"
36
37python __anonymous() {
38    packageconfig = (d.getVar("PACKAGECONFIG") or "").split()
39    flavors = []
40    if "x11-gles2" in packageconfig:
41        flavors.append("x11-glesv2")
42    if "x11-gl" in packageconfig:
43        flavors.append("x11-gl")
44    if "wayland-gles2" in packageconfig:
45        flavors.append("wayland-glesv2")
46    if "wayland-gl" in packageconfig:
47        flavors.append("wayland-gl")
48    if "drm-gles2" in packageconfig:
49        flavors.append("drm-glesv2")
50    if "drm-gl" in packageconfig:
51        flavors.append("drm-gl")
52    if flavors:
53        d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors))
54}
55
56