1SUMMARY = "Tests large file IO and creation/deletion of small files"
2HOMEPAGE = "http://www.coker.com.au/bonnie++/"
3SECTION = "benchmark/tests"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
6
7SRC_URI = "http://www.coker.com.au/bonnie++/${BPN}_${PV}.tgz \
8"
9SRC_URI[sha256sum] = "507bd2ce5360c7c98b91b0fdc2bed5c9320b5c9699f7d4a3d1c86b256896c15e"
10
11inherit autotools-brokensep
12
13SCRIPTS = "bon_csv2html bon_csv2txt"
14EXES = "bonnie++ zcav"
15
16TARGET_CC_ARCH += "${LDFLAGS}"
17
18do_install () {
19    install -d ${D}/${bindir}
20    install -d ${D}/${sbindir}
21    install -m 0755 ${EXES} ${D}/${sbindir}
22    install -m 0755 ${SCRIPTS} ${D}/${bindir}
23}
24
25PACKAGES =+ "bonnie-scripts"
26
27FILES:${PN} = "${sbindir}"
28FILES:bonnie-scripts = "${bindir}"
29
30RDEPENDS:bonnie-scripts += "perl"
31