1SUMMARY = "mongodb"
2LICENSE = "SSPL-1 & Apache-2.0 & Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE-Community.txt;md5=3a865f27f11f43ecbe542d9ea387dcf1 \
4                    file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS = "openssl libpcap zlib boost curl python3 \
7           python3-setuptools-native \
8           python3-pyyaml-native python3-cheetah-native \
9           python3-psutil-native python3-regex-native \
10           "
11
12inherit scons dos2unix siteinfo python3native systemd useradd
13
14PV = "4.4.13"
15#v4.4.13
16SRCREV = "df25c71b8674a78e17468f48bcda5285decb9246"
17SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4;protocol=https \
18           file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \
19           file://0001-Use-long-long-instead-of-int64_t.patch \
20           file://0001-Use-__GLIBC__-to-control-use-of-gnu_get_libc_version.patch \
21           file://0002-Add-a-definition-for-the-macro-__ELF_NATIVE_CLASS.patch \
22           file://arm64-support.patch \
23           file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \
24           file://0001-Support-deprecated-resolver-functions.patch \
25           file://0003-Fix-unknown-prefix-env.patch \
26           file://1296.patch \
27           file://0001-Fix-compilation-with-fno-common.patch \
28           file://0001-stacktrace-Define-ARCH_BITS-for-x86.patch \
29           file://0001-include-needed-c-header.patch \
30           file://disable_runtime_check.patch \
31           file://ppc64_ARCH_BITS.patch \
32           file://PTHREAD_STACK_MIN.patch \
33           file://0001-add-explict-static_cast-size_t-to-maxMemoryUsageByte.patch \
34           file://0001-server-Adjust-the-cache-alignment-assumptions.patch \
35           "
36SRC_URI:append:libc-musl ="\
37           file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \
38           file://0002-Fix-default-stack-size-to-256K.patch \
39           file://0004-wiredtiger-Disable-strtouq-on-musl.patch \
40           "
41
42SRC_URI:append:toolchain-clang = "\
43           file://0001-asio-Dont-use-experimental-with-clang.patch \
44           "
45
46S = "${WORKDIR}/git"
47
48COMPATIBLE_HOST ?= '(x86_64|i.86|powerpc64|arm|aarch64).*-linux'
49
50PACKAGECONFIG ??= "tcmalloc system-pcre"
51# gperftools compilation fails for arm below v7 because of missing support of
52# dmb operation. So we use system-allocator instead of tcmalloc
53PACKAGECONFIG:remove:armv6 = "tcmalloc"
54PACKAGECONFIG:remove:libc-musl = "tcmalloc"
55PACKAGECONFIG:remove:riscv64 = "tcmalloc"
56PACKAGECONFIG:remove:riscv32 = "tcmalloc"
57
58PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools,"
59PACKAGECONFIG[shell] = ",--js-engine=none,,"
60PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre,"
61
62MONGO_ARCH ?= "${HOST_ARCH}"
63MONGO_ARCH:powerpc64le = "ppc64le"
64WIREDTIGER ?= "off"
65WIREDTIGER:x86-64 = "on"
66WIREDTIGER:aarch64 = "on"
67
68EXTRA_OESCONS = "PREFIX=${prefix} \
69                 DESTDIR=${D} \
70                 LIBPATH=${STAGING_LIBDIR} \
71                 LINKFLAGS='${LDFLAGS}' \
72                 CXXFLAGS='${CXXFLAGS}' \
73                 TARGET_ARCH=${MONGO_ARCH} \
74                 MONGO_VERSION=${PV} \
75                 OBJCOPY=${OBJCOPY} \
76                 --ssl \
77                 --disable-warnings-as-errors \
78                 --use-system-zlib \
79                 --nostrip \
80                 --endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
81                 --wiredtiger='${WIREDTIGER}' \
82                 --separate-debug \
83                 ${PACKAGECONFIG_CONFARGS}"
84
85USERADD_PACKAGES = "${PN}"
86USERADD_PARAM:${PN} = "--system --no-create-home --home-dir /var/run/${BPN} --shell /bin/false --user-group ${BPN}"
87
88scons_do_compile() {
89    ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} ${EXTRA_OESCONS} install-core ||
90        die "scons build execution failed."
91}
92
93scons_do_install() {
94    # install binaries
95    install -d ${D}${bindir}
96    for i in mongod mongos mongo; do
97        if [ -f ${B}/build/opt/mongo/$i ]; then
98            install -m 0755 ${B}/build/opt/mongo/$i ${D}${bindir}
99        else
100            bbnote "$i does not exist"
101        fi
102    done
103
104    # install config
105    install -d ${D}${sysconfdir}
106    install -m 0644 ${S}/debian/mongod.conf ${D}${sysconfdir}
107
108    # install systemd service
109    install -d ${D}${systemd_system_unitdir}
110    install -m 0644 ${S}/debian/mongod.service ${D}${systemd_system_unitdir}
111
112    # install mongo data folder
113    install -m 755 -d ${D}${localstatedir}/lib/${BPN}
114    chown ${PN}:${PN} ${D}${localstatedir}/lib/${BPN}
115
116    # Create /var/log/mongodb in runtime.
117    if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then
118        install -d ${D}${nonarch_libdir}/tmpfiles.d
119        echo "d ${localstatedir}/log/${BPN} 0755 ${BPN} ${BPN} -" > ${D}${nonarch_libdir}/tmpfiles.d/${BPN}.conf
120    fi
121    if [ "${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)}" ]; then
122        install -d ${D}${sysconfdir}/default/volatiles
123        echo "d ${BPN} ${BPN} 0755 ${localstatedir}/log/${BPN} none" > ${D}${sysconfdir}/default/volatiles/99_${BPN}
124    fi
125}
126
127CONFFILES:${PN} = "${sysconfdir}/mongod.conf"
128
129SYSTEMD_SERVICE:${PN} = "mongod.service"
130
131FILES:${PN} += "${nonarch_libdir}/tmpfiles.d"
132