1SUMMARY = "The network configuration abstraction renderer"
2DESCRIPTION = "Netplan is a utility for easily configuring networking on a \
3linux system. You simply create a YAML description of the required network \
4interfaces and what each should be configured to do. From this description \
5Netplan will generate all the necessary configuration for your chosen renderer \
6tool."
7HOMEPAGE = "https://netplan.io"
8SECTION = "net/misc"
9
10LICENSE = "GPL-3.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
12
13inherit meson pkgconfig systemd python3targetconfig features_check
14
15REQUIRED_DISTRO_FEATURES = "systemd"
16
17SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \
18           file://0001-meson.build-drop-unnecessary-build-dependencies.patch \
19           file://0002-meson.build-do-not-use-Werror.patch \
20          "
21
22SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch"
23SRC_URI:append:toolchain-clang = " file://0001-networkd.c-define-scope-specific-to-case-statement.patch"
24
25SRCREV = "45f7cd1569896d9e316c130bf5c60b7ccfc8211d"
26
27S = "${WORKDIR}/git"
28
29DEPENDS = "glib-2.0 libyaml util-linux-libuuid \
30           systemd python3-cffi-native \
31          "
32
33EXTRA_OEMESON = "-Dunit_testing=false"
34
35RDEPENDS:${PN} = "python3-core python3-netifaces python3-pyyaml \
36                  python3-dbus python3-rich python3-cffi \
37                  util-linux-libuuid libnetplan \
38                 "
39
40do_install:append() {
41    install -d -m 755 ${D}${sysconfdir}/netplan
42}
43
44PACKAGES += "${PN}-dbus libnetplan"
45
46FILES:libnetplan = "${libdir}/libnetplan.so.*"
47FILES:${PN} = "${sbindir} ${libexecdir}/netplan/generate \
48               ${datadir}/netplan ${datadir}/bash-completion \
49               ${systemd_unitdir} ${PYTHON_SITEPACKAGES_DIR} \
50               ${sysconfdir}/netplan \
51              "
52FILES:${PN}-dbus = "${libexecdir}/netplan/netplan-dbus ${datadir}/dbus-1"
53