1inherit image_types
2
3CONVERSIONTYPES += "sparse"
4CONVERSION_CMD:sparse() {
5    in="${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type}"
6    out="${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.${type}.sparse"
7    case "${type}" in
8        ext*)
9            ext2simg "$in" "$out"
10            ;;
11        *)
12            img2simg "$in" "$out"
13            ;;
14    esac
15}
16CONVERSION_DEPENDS_sparse = "android-tools-native"
17