1SUMMARY = "A sophisticated network protocol analyzer"
2HOMEPAGE = "http://www.tcpdump.org/"
3SECTION = "net"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453"
6
7DEPENDS = "libpcap"
8
9RDEPENDS:${PN}-ptest += " make perl \
10	perl-module-file-basename \
11	perl-module-file-spec \
12	perl-module-file-spec-unix \
13	perl-module-file-path \
14	perl-module-file-glob \
15	perl-module-data-dumper \
16	perl-module-bytes \
17	perl-module-posix \
18	perl-module-carp \
19	perl-module-cwd \
20    perl-module-constant \
21"
22
23SRC_URI = " \
24    http://www.tcpdump.org/release/${BP}.tar.gz \
25    file://add-ptest.patch \
26    file://run-ptest \
27"
28
29SRC_URI[sha256sum] = "0232231bb2f29d6bf2426e70a08a7e0c63a0d59a9b44863b7f5e2357a6e49fea"
30
31UPSTREAM_CHECK_REGEX = "tcpdump-(?P<pver>\d+(\.\d+)+)\.tar"
32
33inherit autotools-brokensep pkgconfig ptest
34
35PACKAGECONFIG ?= "openssl"
36
37PACKAGECONFIG[libcap-ng] = "--with-cap-ng,--without-cap-ng,libcap-ng"
38PACKAGECONFIG[openssl] = "--with-crypto,--without-crypto,openssl"
39PACKAGECONFIG[smi] = "--with-smi,--without-smi,libsmi"
40# Note: CVE-2018-10103 (SMB - partially fixed, but SMB printing disabled)
41PACKAGECONFIG[smb] = "--enable-smb,--disable-smb"
42
43EXTRA_AUTORECONF += "--exclude=aclocal"
44
45do_install:append() {
46    # make install installs an unneeded extra copy of the tcpdump binary
47    rm ${D}${bindir}/tcpdump.${PV}
48}
49
50do_compile_ptest() {
51    oe_runmake buildtest-TESTS
52}
53