1#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4
5SUMMARY = "Simple Protocol for Independent Computing Environments"
6DESCRIPTION = "SPICE (the Simple Protocol for Independent Computing \
7Environments) is a remote-display system built for virtual \
8environments which allows users to view a computing 'desktop' \
9environment - not only on its computer-server machine, but also from \
10anywhere on the Internet and using a wide variety of machine \
11architectures."
12
13LICENSE = "LGPL-2.1-or-later"
14LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
15
16PV = "0.14.2+git${SRCPV}"
17
18SRCREV_spice = "7cbd70b931db76c69c89c2d9d5d704f67381a81b"
19SRCREV_spice-common = "4fc4c2db36c7f07b906e9a326a9d3dc0ae6a2671"
20
21SRCREV_FORMAT = "spice_spice-common"
22
23SRC_URI = " \
24    git://anongit.freedesktop.org/spice/spice;name=spice;branch=master \
25    git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common;branch=master \
26    file://0001-Convert-pthread_t-to-be-numeric.patch \
27    file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
28    file://0001-configure.ac-explicitly-link-to-jpeg-lib.patch \
29"
30
31S = "${WORKDIR}/git"
32
33CVE_CHECK_IGNORE += "\
34    CVE-2016-0749 \
35    CVE-2016-2150 \
36    CVE-2018-10893 \
37"
38
39inherit autotools gettext python3native python3-dir pkgconfig
40
41DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python3-pyparsing-native python3-six-native glib-2.0-native"
42DEPENDS:append:class-nativesdk = " nativesdk-openssl"
43
44export PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
45
46CFLAGS:append = " -Wno-error"
47
48PACKAGECONFIG:class-native = ""
49PACKAGECONFIG:class-nativesdk = ""
50PACKAGECONFIG ?= "sasl"
51
52PACKAGECONFIG[celt051] = "--enable-celt051,--disable-celt051,celt051"
53PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
54PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
55PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
56PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
57PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus,"
58PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
59PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
60
61COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
62
63BBCLASSEXTEND = "native nativesdk"
64
65EXTRA_OECONF:append:toolchain-clang = " --disable-werror"
66