1SUMMARY = "phodav is a WebDav server implementation using libsoup (RFC 4918)."
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
5DEPENDS = " \
6    glib-2.0 \
7    libsoup \
8"
9
10GNOMEBASEBUILDCLASS = "meson"
11GTKDOC_MESON_OPTION = 'gtk_doc'
12GTKDOC_MESON_ENABLE_FLAG = 'enabled'
13GTKDOC_MESON_DISABLE_FLAG = 'disabled'
14
15PACKAGECONFIG ??= "avahi"
16PACKAGECONFIG[avahi] = "-Davahi=enabled,-Davahi=disabled,avahi"
17
18inherit pkgconfig gnomebase gettext gtk-doc
19
20EXTRA_OEMESON += "-Dsystemdsystemunitdir=${systemd_system_unitdir}"
21
22SRC_URI = "https://download.gnome.org/sources/phodav/3.0/phodav-${PV}.tar.xz;name=archive"
23SRC_URI[archive.sha256sum] = "392ec2d06d50300dcff1ef269a2a985304e29bce3520002fca29f2edc1d138d1"
24
25FILES:${PN} += "${libdir} ${systemd_system_unitdir}"
26