1SUMMARY = "IPMI (Intelligent Platform Management Interface) library and tools"
2DESCRIPTION = "OpenIPMI is an effort to create a full-function IPMI system, \
3to allow full access to all IPMI information on a server \
4and to abstract it to a level that will make it easy to use"
5
6HOMEPAGE = "http://openipmi.sourceforge.net"
7
8DEPENDS = " \
9    glib-2.0 \
10    ncurses \
11    net-snmp \
12    openssl \
13    popt \
14    python3 \
15    swig-native \
16    readline \
17    "
18
19LICENSE = "GPL-2.0-only & LGPL-2.1-only & BSD-3-Clause"
20
21LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
22                    file://COPYING.LIB;md5=d8045f3b8f929c1cb29a1e3fd737b499 \
23                    file://COPYING.BSD;md5=4b318d4160eb69c8ee53452feb1b4cdf \
24                    "
25
26SRC_URI = "${SOURCEFORGE_MIRROR}/openipmi/OpenIPMI-${PV}.tar.gz \
27           file://fix-symlink-install-error-in-cmdlang.patch \
28           file://openipmi-no-openipmigui-man.patch \
29           file://ipmi-init-fix-the-arguments.patch \
30           file://include_sys_types.patch \
31           file://openipmi-helper \
32           file://ipmi.service \
33           "
34
35S = "${WORKDIR}/OpenIPMI-${PV}"
36
37SRC_URI[sha256sum] = "93227e43c72b5c3bd5949323e0669aa5527d1a971473a3a365af03fb8284a95f"
38
39inherit autotools-brokensep pkgconfig perlnative update-rc.d systemd cpan-base python3targetconfig
40
41CFLAGS += "-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
42
43EXTRA_OECONF = "--disable-static \
44                --with-perl='${STAGING_BINDIR_NATIVE}/perl-native/perl' \
45                --with-glibver=2.0"
46
47PACKAGECONFIG ??= "gdbm"
48PACKAGECONFIG[gdbm] = "ac_cv_header_gdbm_h=yes,ac_cv_header_gdbm_h=no,gdbm,"
49
50PACKAGES += "${PN}-perl ${PN}-python"
51PRIVATE_LIBS:${PN}-perl = "libOpenIPMI.so.0"
52
53FILES:${PN}-perl = " \
54    ${libdir}/perl/vendor_perl/*/OpenIPMI.pm \
55    ${libdir}/perl/vendor_perl/*/auto/OpenIPMI/OpenIPMI.so \
56    "
57
58FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
59
60FILES:${PN}-dbg += " \
61    ${libdir}/perl/vendor_perl/*/auto/OpenIPMI/.debug \
62    ${PYTHON_SITEPACKAGES_DIR}/.debug \
63    "
64
65do_configure () {
66    # Let's perform regular configuration first then handle perl issues.
67    PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI} autotools_do_configure
68
69    perl_ver=`perl -V:version | cut -d\' -f 2`
70
71    # Force openipmi perl bindings to be compiled using perl-native instead of
72    # the host's perl. Set the proper install directory for the resulting
73    # openipmi.pm and openipmi.so
74    for i in ${S}/swig/Makefile ${S}/swig/perl/Makefile; do
75        echo "SAL: i = $i"
76        echo "SAL: STAGING_INCDIR_NATIVE = $STAGING_INCDIR_NATIVE"
77        echo "SAL: libdir = $libdir"
78        sed -i -e "/^PERL_CFLAGS/s:-I/usr/local/include:-I${STAGING_INCDIR_NATIVE}:g" $i
79        sed -i -e "/^PERL_CFLAGS/s:-I .* :-I ${STAGING_LIBDIR}${PERL_OWN_DIR}/perl5/${@get_perl_version(d)}/${@get_perl_arch(d)}/CORE :g" $i
80        sed -i -e "/^PERL_INSTALL_DIR/s:^PERL_INSTALL_DIR = .*:PERL_INSTALL_DIR = ${libdir}/perl/vendor_perl/$perl_ver:g" $i
81    done
82}
83
84do_compile:append () {
85    sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' ${S}/swig/perl/OpenIPMI_wrap.c
86}
87
88do_install:append () {
89    echo "SAL: D = $D"
90    echo "SAL: libdir = $libdir"
91    install -m 0755 -d ${D}${sysconfdir}/sysconfig ${D}${sysconfdir}/init.d
92    install -m 0755 ${S}/ipmi.init ${D}${sysconfdir}/init.d/ipmi
93    install -m 0644 ${S}/ipmi.sysconf ${D}${sysconfdir}/sysconfig/ipmi
94    # SAL: mv: cannot stat `/localdisk/loadbuild/slittle1/workspace/cgts_test_build/bitbake_build/tmp/work/x86_64-wrs-linux/openipmi-2.0.19-r4/image/usr/lib64/perl5': No such file or directory
95    # SAL: real path to perl is /localdisk/loadbuild/slittle1/workspace/cgts_test_build/bitbake_build/tmp/work/x86_64-wrs-linux/perl-5.14.2-r8.3/package/usr/lib64/perl5 and it is a symlink to perl so no need to mv.
96    if [ -d ${D}${libdir}/perl5 ]
97    then
98        mv ${D}${libdir}/perl5 ${D}${libdir}/perl
99    fi
100
101    # for systemd
102    install -d ${D}${systemd_unitdir}/system
103    install -m 0664 ${WORKDIR}/ipmi.service ${D}${systemd_unitdir}/system
104    sed -i -e "s,@LIBEXECDIR@,${libexecdir},g" ${D}${systemd_unitdir}/system/ipmi.service
105    install -d ${D}${libexecdir}
106    install -m 0755 ${WORKDIR}/openipmi-helper ${D}${libexecdir}
107}
108
109INITSCRIPT_NAME = "ipmi"
110INITSCRIPT_PARAMS = "start 30 . stop 70 0 1 2 3 4 5 6 ."
111
112SYSTEMD_SERVICE:${PN} = "ipmi.service"
113SYSTEMD_AUTO_ENABLE = "disable"
114