1SUMMARY = "Network time synchronization software, NTPD replacement"
2DESCRIPTION = "This is a preview/early-access/alpha/buzzword-of-the-times \
3release of a new FOSS project written to gradually take over the world of \
4networked timekeeping."
5HOMEPAGE = "https://github.com/bsdphk/Ntimed"
6SECTION = "net"
7
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://main.c;beginline=2;endline=24;md5=89db8e76f2951f3fad167e7aa9718a44"
10
11SRC_URI = "git://github.com/bsdphk/Ntimed;branch=master;protocol=https \
12           file://use-ldflags.patch"
13
14PV = "0.0+git${SRCPV}"
15SRCREV = "db0abbb4c80f2ecef6bc5d9639bca5bea28532a2"
16
17S = "${WORKDIR}/git"
18
19# use adjtimex on musl
20CFLAGS:append:libc-musl = " -Dntp_adjtime=adjtimex"
21
22EXTRA_OEMAKE = "\
23    'CC=${CC}' \
24    'CFLAGS=${CFLAGS}' \
25    'LDFLAGS=${LDFLAGS}' \
26"
27
28do_configure () {
29    sh ${S}/configure
30}
31
32do_install () {
33    install -D -m 0755 ntimed-client ${D}${sbindir}/ntimed-client
34}
35
36ALLOW_EMPTY:${PN} = "1"
37RDEPENDS:${PN} += "ntimed-client"
38
39PACKAGE_BEFORE_PN += "ntimed-client"
40FILES:ntimed-client = "${sbindir}/ntimed-client"
41