1SUMMARY = "a fast file copy tool for LANs"
2DESCRIPTION = "ncp is a utility for copying files in a LAN. It has absolutely no \
3security or integrity checking, no throttling, no features, except \
4one: you don't have to type the coordinates of your peer."
5HOMEPAGE = "http://www.fefe.de/ncp"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
8DEPENDS = "libowfat"
9
10SRC_URI = "https://dl.fefe.de/${BP}.tar.bz2"
11SRC_URI[md5sum] = "421c4855bd3148b7d0a4342942b4bf13"
12SRC_URI[sha256sum] = "6cfa72edd5f7717bf7a4a93ccc74c4abd89892360e2e0bb095a73c24b9359b88"
13
14EXTRA_OEMAKE = "\
15    DIET= \
16    DEBUG=nostrip \
17    CC='${CC}' CFLAGS='${CFLAGS} -I${STAGING_INCDIR}/libowfat' LDFLAGS='${LDFLAGS}' \
18"
19
20do_install() {
21    install -d -m0755 ${D}${bindir} ${D}${mandir}/man1
22
23    install -m0755 ncp ${D}${bindir}
24    ln -sf ncp ${D}${bindir}/npoll
25    ln -sf ncp ${D}${bindir}/npush
26
27    install -m0644 ncp.1 npush.1 ${D}${mandir}/man1
28    ln -sf npush.1 ${D}${mandir}/man1/npoll.1
29}
30
31BBCLASSEXTEND = "native nativesdk"
32