1SUMMARY = "Utilities for managing the Linux LoWPAN stack"
2DESCRIPTION = "This is a set of utils to manage the Linux LoWPAN stack. \
3The LoWPAN stack aims for IEEE 802.15.4-2003 (and for lesser extent IEEE 802.15.4-2006) compatibility."
4SECTION = "net"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8DEPENDS = "flex-native bison-native libnl python"
9
10PV = "0.3.1+git${SRCPV}"
11SRC_URI = "git://github.com/linux-wpan/lowpan-tools;branch=master;protocol=https \
12           file://no-help2man.patch \
13           file://0001-Fix-build-errors-with-clang.patch \
14           file://0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch \
15           file://0001-src-iz.c-Undef-dprintf-before-redefining.patch \
16           file://0001-Remove-newline-from-format-line.patch \
17           file://0001-coordinator-Fix-strncpy-range-warning.patch \
18           file://0001-Fix-potential-string-truncation-in-strncpy.patch \
19           "
20SRCREV = "1c2d8674cc6f4b1166a066e8822e295c105ae7a2"
21
22S = "${WORKDIR}/git"
23
24inherit autotools python3-dir pkgconfig
25
26CACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools"
27
28CFLAGS += "-Wno-initializer-overrides"
29
30do_install:append() {
31    rmdir ${D}${localstatedir}/run
32}
33
34FILES:${PN}-dbg += "${libexecdir}/lowpan-tools/.debug/"
35
36PACKAGES =+ "${PN}-python"
37FILES:${PN}-python = "${libdir}/python*"
38
39PNBLACKLIST[lowpan-tools] ?= "WARNING these tools are deprecated! Use wpan-tools instead"
40