1eb8dc403SDave CobbleySUMMARY = "Utilities for managing the Linux LoWPAN stack"
2eb8dc403SDave CobbleyDESCRIPTION = "This is a set of utils to manage the Linux LoWPAN stack. \
3eb8dc403SDave CobbleyThe LoWPAN stack aims for IEEE 802.15.4-2003 (and for lesser extent IEEE 802.15.4-2006) compatibility."
4eb8dc403SDave CobbleySECTION = "net"
59aee5003SAndrew GeisslerLICENSE = "GPL-2.0-only"
6eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7eb8dc403SDave Cobbley
8eb8dc403SDave CobbleyDEPENDS = "flex-native bison-native libnl python"
9eb8dc403SDave Cobbley
10*73bd93f1SPatrick WilliamsPV = "0.3.1+git"
11595f6308SAndrew GeisslerSRC_URI = "git://github.com/linux-wpan/lowpan-tools;branch=master;protocol=https \
12eb8dc403SDave Cobbley           file://no-help2man.patch \
13eb8dc403SDave Cobbley           file://0001-Fix-build-errors-with-clang.patch \
14eb8dc403SDave Cobbley           file://0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch \
15eb8dc403SDave Cobbley           file://0001-src-iz.c-Undef-dprintf-before-redefining.patch \
16eb8dc403SDave Cobbley           file://0001-Remove-newline-from-format-line.patch \
17eb8dc403SDave Cobbley           file://0001-coordinator-Fix-strncpy-range-warning.patch \
181a4b7ee2SBrad Bishop           file://0001-Fix-potential-string-truncation-in-strncpy.patch \
19eb8dc403SDave Cobbley           "
20eb8dc403SDave CobbleySRCREV = "1c2d8674cc6f4b1166a066e8822e295c105ae7a2"
21eb8dc403SDave Cobbley
22eb8dc403SDave CobbleyS = "${WORKDIR}/git"
23eb8dc403SDave Cobbley
2482c905dcSAndrew Geisslerinherit autotools python3-dir pkgconfig
25eb8dc403SDave Cobbley
26eb8dc403SDave CobbleyCACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools"
27eb8dc403SDave Cobbley
28eb8dc403SDave CobbleyCFLAGS += "-Wno-initializer-overrides"
29eb8dc403SDave Cobbley
30213cb269SPatrick Williamsdo_install:append() {
31eb8dc403SDave Cobbley    rmdir ${D}${localstatedir}/run
32eb8dc403SDave Cobbley}
33eb8dc403SDave Cobbley
34213cb269SPatrick WilliamsFILES:${PN}-dbg += "${libexecdir}/lowpan-tools/.debug/"
35eb8dc403SDave Cobbley
36eb8dc403SDave CobbleyPACKAGES =+ "${PN}-python"
37213cb269SPatrick WilliamsFILES:${PN}-python = "${libdir}/python*"
3887b3cb80SBrad Bishop
397e0e3c0cSAndrew GeisslerSKIP_RECIPE[lowpan-tools] ?= "WARNING these tools are deprecated! Use wpan-tools instead"
40