1SUMMARY = "HTTP request/response parser for C"
2DESCRIPTION = "This is a parser for HTTP messages written in C. It parses \
3              both requests and responses. The parser is designed to be used \
4              in performance HTTP applications. It does not make any \
5              syscalls nor allocations, it does not buffer data, it can be \
6              interrupted at anytime. Depending on your architecture, it \
7              only requires about 40 bytes of data per message stream (in a \
8              web server that is per connection)."
9HOMEPAGE = "https://github.com/nodejs/http-parser"
10SECTION = "libs"
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=9bfa835d048c194ab30487af8d7b3778"
13
14SRC_URI = "git://github.com/nodejs/http-parser.git;branch=master;protocol=https"
15SRCREV = "2343fd6b5214b2ded2cdcf76de2bf60903bb90cd"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = "PLATFORM=linux"
20
21do_configure[noexec] = "1"
22
23do_compile() {
24    oe_runmake library package
25}
26
27do_install() {
28    oe_runmake install DESTDIR=${D} PREFIX=${prefix} LIBDIR=${libdir}
29}
30
31BBCLASSEXTEND = "native nativesdk"
32