1SUMMARY = "C++ library for client-side URL transfers"
2HOMEPAGE = "http://www.curlpp.org/"
3SECTION = "libdevel"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=fd0c9adf285a69aa3b4faf34384e1029"
6
7DEPENDS = "curl"
8DEPENDS:class-native = "curl-native"
9
10SRC_URI = "git://github.com/jpbarrette/curlpp.git;branch=master;protocol=https \
11           file://0001-curlpp-config.in-Remove-references-to-absolute-build.patch"
12
13SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f"
14
15S = "${WORKDIR}/git"
16
17inherit cmake pkgconfig binconfig
18
19BBCLASSEXTEND = "native nativesdk"
20
21do_install:append() {
22    sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
23        -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
24        -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
25        -i ${D}${libdir}/pkgconfig/*.pc
26}
27