1DESCRIPTION = "This is a userland SCTP stack supporting FreeBSD, Linux, Mac OS X and Windows."
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.md;md5=ffcf846341f3856d79a483eafa18e2a5"
4
5SRCREV = "dbfc1b8c4cf1a46a4d8987ba542d5ff06bdaf14c"
6SRC_URI = "git://github.com/sctplab/usrsctp;protocol=https;branch=master \
7           file://0001-Use-foreign-switch-for-automake.patch \
8          "
9
10S = "${WORKDIR}/git"
11
12inherit autotools pkgconfig
13
14DEPENDS += "openssl"
15
16CFLAGS  += "-DSCTP_USE_OPENSSL_SHA1 -fPIC"
17LDFLAGS += "-lssl -lcrypto"
18
19PACKAGECONFIG ?= "disablewarnings inet inet6"
20PACKAGECONFIG[disablewarnings] = "--disable-warnings-as-errors,,"
21PACKAGECONFIG[inet] = "--enable-inet,--disable-inet,"
22PACKAGECONFIG[inet6] = "--enable-inet6,--disable-inet6,"
23
24EXTRA_OECONF += "--disable-debug"
25