1SUMMARY = "Libraries and wrapper for using a SOCKS proxy"
2DESCRIPTION = "The role of tsocks is to allow non SOCKS aware \
3applications (e.g telnet, ssh, ftp etc) to use SOCKS without any \
4modification. It does this by intercepting the calls that applications \
5make to establish network connections and negotating them through a \
6SOCKS server as necessary."
7HOMEPAGE = "http://sourceforge.net/projects/tsocks/"
8SECTION = "net"
9LICENSE = "GPL-2.0-only"
10LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
11
12SRC_URI = "http://downloads.sourceforge.net/tsocks/tsocks-${PV}.tar.gz \
13           file://makefile-add-ldflags.patch \
14          "
15
16SRC_URI[md5sum] = "51caefd77e5d440d0bbd6443db4fc0f8"
17SRC_URI[sha256sum] = "849d7ef5af80d03e76cc05ed9fb8fa2bcc2b724b51ebfd1b6be11c7863f5b347"
18
19inherit autotools-brokensep
20
21LIBS:append:libc-musl = " -lssp_nonshared"
22LIBS:append:libc-glibc = " -lc_nonshared"
23
24S = "${WORKDIR}/tsocks-1.8"
25
26FILES:${PN} = "${libdir}/* ${bindir}/tsocks"
27FILES:${PN}-dev = ""
28INSANE_SKIP:${PN} = "dev-so"
29
30EXTRA_OEMAKE = "SHCC='${CC} -fPIC ${LDFLAGS}' LIBS='${LIBS}'"
31
32