1SUMMARY = "RADIUS protocol client library"
2DESCRIPTION = "Portable, easy-to-use and standard compliant library suitable \
3for developing free and commercial software that need support for a RADIUS \
4protocol (RFCs 2128 and 2139)."
5HOMEPAGE = "http://sourceforge.net/projects/radiusclient-ng.berlios/"
6SECTION = "net"
7
8SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/r/${BPN}/${BPN}_${PV}.orig.tar.gz \
9   file://Modify-configure.in-and-etc-Makefile.am.patch \
10   file://config-site.radiusclient-ng-${PV}"
11
12SRC_URI[sha256sum] = "282a9f1355f190efbb06c0d7c4e062eaa652caf342ed3ad361ac595f72f09f14"
13
14LICENSE = "BSD-3-Clause & BSD-2-Clause & HPND"
15LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=3e47566c9271b786693d8a08792dbf41"
16
17inherit autotools-brokensep
18
19DEPENDS += "virtual/crypt"
20
21EXTRA_OECONF += "--disable-static"
22
23do_configure:prepend () {
24    export CONFIG_SITE=./config-site.${P}
25}
26
27do_compile:prepend() {
28    for m in `find . -name "Makefile"` ; do
29        sed -i -e 's:^program_transform_name =.*:program_transform_name =:g' ${m}
30    done
31}
32
33do_install() {
34    oe_runmake DESTDIR=${D} install
35    rm -f ${D}${libdir}/*.la
36    rm -f ${D}${sbindir}/radexample
37}
38