1SUMMARY = "Babel is a loop-avoiding distance-vector routing protocol"
2DESCRIPTION = "\
3Babel is a loop-avoiding distance-vector routing protocol for IPv6 and \
4IPv4 with fast convergence properties. It is based on the ideas in DSDV, AODV \
5and Cisco's EIGRP, but is designed to work well not only in wired networks \
6but also in wireless mesh networks, and has been extended with support \
7for overlay networks. Babel is in the process of becoming an IETF Standard. \
8"
9HOMEPAGE = "https://www.irif.fr/~jch/software/babel/"
10SECTION = "net"
11
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENCE;md5=411a48ac3c2e9e0911b8dd9aed26f754"
14
15SRC_URI = "gitsm://github.com/jech/babeld.git;protocol=https;branch=master"
16SRCREV = "3d61ea1e843e2c5f9706c74d1adad4e1d24d44b9"
17
18UPSTREAM_CHECK_GITTAGREGEX = "babeld-(?P<pver>\d+(\.\d+)+)"
19
20S = "${WORKDIR}/git"
21
22EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
23
24do_compile () {
25	oe_runmake babeld
26}
27
28do_install () {
29	oe_runmake install.minimal TARGET=${D} PREFIX=${root_prefix}
30}
31
32