1SUMMARY = "ZNC, an advanced IRC bouncer"
2SECTION = "net"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS = "openssl zlib icu"
7
8SRC_URI = "git://github.com/znc/znc.git;name=znc;branch=master;protocol=https \
9           git://github.com/jimloco/Csocket.git;destsuffix=git/third_party/Csocket;name=Csocket;branch=master;protocol=https \
10          "
11SRCREV_znc = "bf253640d33d03331310778e001fb6f5aba2989e"
12SRCREV_Csocket = "e8d9e0bb248c521c2c7fa01e1c6a116d929c41b4"
13
14# This constructs a composite revision based on multiple SRCREV's.
15#
16SRCREV_FORMAT = "znc_Csocket"
17
18S = "${WORKDIR}/git"
19
20inherit autotools-brokensep pkgconfig
21
22PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
23PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
24
25# ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
26do_configure:prepend() {
27    automake --add-missing || true
28}
29
30do_install:append() {
31    sed -i -e 's|${DEBUG_PREFIX_MAP}||g; s|--sysroot=${STAGING_DIR_TARGET}||g' ${D}${libdir}/pkgconfig/*.pc
32}
33