1SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification"
2DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \
3middleware consistent with Service Availability Forum (SA Forum) \
4specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \
5established by leading Communications and Enterprise Computing Companies to \
6facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \
7code base in commercial products. \
8The OpenSAF project was launched in mid 2007 and has been under development by \
9an informal group of supporters of the OpenSAF initiative. The OpenSAF \
10Foundation was founded on January 22nd 2008 with Emerson Network Power, \
11Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
12HOMEPAGE = "http://www.opensaf.org"
13SECTION = "admin"
14LICENSE = "LGPL-2.1-only"
15LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
16
17DEPENDS = "libxml2 python3"
18TOOLCHAIN = "gcc"
19
20SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
21
22SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
23           file://0001-configure-Pass-linker-specific-options-with-Wl.patch \
24           file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \
25           file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \
26           file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
27           file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \
28           file://0001-immom_python-convert-to-python3.patch \
29           file://0001-Fix-build-with-fno-common.patch \
30           file://0001-Use-correct-printf-format-for-__fsblkcnt_t.patch \
31           file://0001-include-missing-array-header.patch \
32           file://0002-configure-Disable-selected-warnings.patch \
33           "
34SRC_URI[sha256sum] = "f008d53c83087ce2014c6089bc4ef08e14c1b4091298b943f4ceade1aa6bf61e"
35
36UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/opensaf/files/releases"
37
38inherit autotools useradd systemd pkgconfig
39
40USERADD_PACKAGES = "${PN}"
41GROUPADD_PARAM:${PN} = "-f -r opensaf"
42USERADD_PARAM:${PN} =  "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
43
44SYSTEMD_SERVICE:${PN} += "opensafd.service"
45SYSTEMD_AUTO_ENABLE = "disable"
46
47PACKAGECONFIG[systemd] = ",,systemd"
48PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03,,openhpi"
49PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi"
50
51PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
52
53CPPFLAGS += "-Wno-error"
54CXXFLAGS += "-Wno-error"
55LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
56
57do_install:append() {
58    rm -fr "${D}${localstatedir}/lock"
59    rm -fr "${D}${localstatedir}/run"
60    rmdir "${D}${localstatedir}/log/${BPN}/saflog"
61    rmdir "${D}${localstatedir}/log/${BPN}"
62    rmdir "${D}${localstatedir}/log"
63    rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
64    rmdir --ignore-fail-on-non-empty "${D}${datadir}/java"
65
66    # Rename /etc/init.d/opensafd to /usr/lib/opensaf/opensafd-init as it is
67    # needed by opensafd.service, but /etc/init.d is removed by systemd.bbclass
68    # if sysvinit is not in DISTRO_FEATURES.
69    mv ${D}${sysconfdir}/init.d/opensafd ${D}${libdir}/${BPN}/opensafd-init
70    ln -srf ${D}${libdir}/${BPN}/opensafd-init ${D}${sysconfdir}/init.d/opensafd
71    [ ! -f ${D}${systemd_system_unitdir}/opensafd.service ] ||
72        sed -ri -e "s|/etc/init.d/opensafd|${libdir}/${BPN}/opensafd-init|" ${D}${systemd_system_unitdir}/opensafd.service
73
74    # Create /var/log/opensaf/saflog in runtime.
75    if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then
76        install -d ${D}${nonarch_libdir}/tmpfiles.d
77        echo "d ${localstatedir}/log/${BPN}/saflog - - - -" > ${D}${nonarch_libdir}/tmpfiles.d/${BPN}.conf
78    fi
79    if [ "${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)}" ]; then
80        install -d ${D}${sysconfdir}/default/volatiles
81        echo "d root root 0755 ${localstatedir}/log/${BPN}/saflog none" > ${D}${sysconfdir}/default/volatiles/99_${BPN}
82    fi
83}
84
85FILES:${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
86FILES:${PN} += "${nonarch_libdir}/tmpfiles.d"
87FILES:${PN}-dev += "${libdir}/libopensaf_core.so"
88FILES:${PN}-staticdev += "${PKGLIBDIR}/*.a"
89
90INSANE_SKIP:${PN} = "dev-so"
91
92RDEPENDS:${PN} += "bash python3-core"
93
94# http://errors.yoctoproject.org/Errors/Details/186970/
95COMPATIBLE_HOST:libc-musl = 'null'
96
97FILES_SOLIBSDEV = ""
98