1SUMMARY = "Dispatcher service for systemd-networkd connection status changes"
2DESCRIPTION = "This daemon is similar to NetworkManager-dispatcher, but is much \
3more limited in the types of events it supports due to the limited nature of \
4systemd-networkd(8)."
5
6LICENSE = "GPL-3.0-only"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
8
9inherit features_check systemd
10
11RDEPENDS:${PN} = "python3-pygobject python3-dbus"
12REQUIRED_DISTRO_FEATURES = "systemd gobject-introspection-data"
13
14SRCREV = "dfd26d72793914eb3da910ef8c71de6d7c8942a2"
15SRC_URI = "git://gitlab.com/craftyguy/networkd-dispatcher;protocol=https;nobranch=1"
16
17S = "${WORKDIR}/git"
18
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE:${PN} = "networkd-dispatcher.service"
21SYSTEMD_AUTO_ENABLE = "disable"
22
23# Nothing to build, just a python script to install
24do_configure[noexec] = "1"
25do_compile[noexec] = "1"
26
27do_install() {
28    install -D -m 0755 ${S}/networkd-dispatcher ${D}${bindir}/networkd-dispatcher
29    install -D -m 0644 ${S}/networkd-dispatcher.service ${D}/${systemd_system_unitdir}/networkd-dispatcher.service
30    install -D -m 0644 ${S}/networkd-dispatcher.conf ${D}/${sysconfdir}/conf.d/networkd-dispatcher.conf
31}
32