1SUMMARY = "VLAN provides vconfig utility"
2HOMEPAGE = "http://www.candelatech.com/~greear/vlan.html"
3SECTION = "misc"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://vconfig.c;beginline=1;endline=19;md5=094ca47de36c20c598b15b32c270ce0a"
6
7SRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz \
8           file://no-HOME-includes.patch \
9           file://0001-Add-printf-format-and-silence-format-security-warnin.patch \
10"
11
12SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394"
13SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca"
14
15S = "${WORKDIR}/${BPN}"
16
17inherit update-alternatives
18
19EXTRA_OEMAKE = "-e MAKEFLAGS="
20
21# comment out MakeInclude in Makefile which sets build environment
22do_configure_append () {
23    sed -i 's/^ include/#^include/' ${S}/Makefile
24}
25
26# ignore strip to avoid yocto errors in stripping
27do_compile () {
28    oe_runmake PLATFORM=ARM 'STRIP=echo' all
29}
30
31do_install () {
32    install -d ${D}/${base_sbindir}
33    install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/
34}
35
36ALTERNATIVE_PRIORITY = "100"
37ALTERNATIVE_${PN} = "vconfig"
38ALTERNATIVE_LINK_NAME[vconfig] = "${base_sbindir}/vconfig"
39