1SUMMARY = "VLAN provides vconfig utility"
2HOMEPAGE = "http://www.candelatech.com/~greear/vlan.html"
3SECTION = "misc"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://vconfig.c;beginline=1;endline=19;md5=094ca47de36c20c598b15b32c270ce0a"
6
7SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/vlan/1.9-3ubuntu10.6/${BPN}_${PV}.orig.tar.gz \
8           file://no-HOME-includes.patch \
9           file://0001-Add-printf-format-and-silence-format-security-warnin.patch \
10"
11
12SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394"
13SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca"
14
15UPSTREAM_CHECK_URI = "http://vlan.sourcearchive.com/"
16UPSTREAM_CHECK_REGEX = "/(?P<pver>\d+(\.\d+)+)/"
17
18S = "${WORKDIR}/${BPN}"
19
20inherit update-alternatives
21
22EXTRA_OEMAKE = "-e MAKEFLAGS="
23
24# comment out MakeInclude in Makefile which sets build environment
25do_configure_append () {
26    sed -i 's/^ include/#^include/' ${S}/Makefile
27}
28
29# ignore strip to avoid yocto errors in stripping
30do_compile () {
31    oe_runmake PLATFORM=ARM 'STRIP=echo' all
32}
33
34do_install () {
35    install -d ${D}/${base_sbindir}
36    install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/
37}
38
39ALTERNATIVE_PRIORITY = "100"
40ALTERNATIVE_${PN} = "vconfig"
41ALTERNATIVE_LINK_NAME[vconfig] = "${base_sbindir}/vconfig"
42