1*eb8dc403SDave CobbleySUMMARY = "VLAN provides vconfig utility"
2*eb8dc403SDave CobbleyHOMEPAGE = "http://www.candelatech.com/~greear/vlan.html"
3*eb8dc403SDave CobbleySECTION = "misc"
4*eb8dc403SDave CobbleyLICENSE = "GPLv2"
5*eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://vconfig.c;beginline=1;endline=19;md5=094ca47de36c20c598b15b32c270ce0a"
6*eb8dc403SDave Cobbley
7*eb8dc403SDave CobbleySRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz \
8*eb8dc403SDave Cobbley           file://no-HOME-includes.patch \
9*eb8dc403SDave Cobbley           file://0001-Add-printf-format-and-silence-format-security-warnin.patch \
10*eb8dc403SDave Cobbley"
11*eb8dc403SDave Cobbley
12*eb8dc403SDave CobbleySRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394"
13*eb8dc403SDave CobbleySRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca"
14*eb8dc403SDave Cobbley
15*eb8dc403SDave CobbleyS = "${WORKDIR}/${BPN}"
16*eb8dc403SDave Cobbley
17*eb8dc403SDave Cobbleyinherit update-alternatives
18*eb8dc403SDave Cobbley
19*eb8dc403SDave CobbleyEXTRA_OEMAKE = "-e MAKEFLAGS="
20*eb8dc403SDave Cobbley
21*eb8dc403SDave Cobbley# comment out MakeInclude in Makefile which sets build environment
22*eb8dc403SDave Cobbleydo_configure_append () {
23*eb8dc403SDave Cobbley    sed -i 's/^ include/#^include/' ${S}/Makefile
24*eb8dc403SDave Cobbley}
25*eb8dc403SDave Cobbley
26*eb8dc403SDave Cobbley# ignore strip to avoid yocto errors in stripping
27*eb8dc403SDave Cobbleydo_compile () {
28*eb8dc403SDave Cobbley    oe_runmake PLATFORM=ARM 'STRIP=echo' all
29*eb8dc403SDave Cobbley}
30*eb8dc403SDave Cobbley
31*eb8dc403SDave Cobbleydo_install () {
32*eb8dc403SDave Cobbley    install -d ${D}/${base_sbindir}
33*eb8dc403SDave Cobbley    install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/
34*eb8dc403SDave Cobbley}
35*eb8dc403SDave Cobbley
36*eb8dc403SDave CobbleyALTERNATIVE_PRIORITY = "100"
37*eb8dc403SDave CobbleyALTERNATIVE_${PN} = "vconfig"
38*eb8dc403SDave CobbleyALTERNATIVE_LINK_NAME[vconfig] = "${base_sbindir}/vconfig"
39