1SUMMARY = "Header-only C++14 library that gives you an embedded HTTP server"
2DESCRIPTION = "Cross-platform, efficient, customizable, and robust \
3               asynchronous HTTP/WebSocket server C++14 library with the \
4               right balance between performance and ease of use"
5HOMEPAGE = "https://stiffstream.com/en/products/restinio.html"
6SECTION = "libs"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://../LICENSE;md5=f399b62ce0a152525d1589a5a40c0ff6"
9DEPENDS = "asio fmt http-parser"
10
11SRC_URI = "https://github.com/Stiffstream/restinio/releases/download/v.${PV}/${BP}.tar.bz2"
12SRC_URI[md5sum] = "37a4310e98912030a74bdd4ed789f33c"
13SRC_URI[sha256sum] = "b35d696e6fafd4563ca708fcecf9d0cf6705c846d417b5000f5252e0188848e7"
14
15S = "${WORKDIR}/${BP}/dev"
16
17inherit cmake
18
19EXTRA_OECMAKE += "\
20                  -DRESTINIO_TEST=OFF \
21                  -DRESTINIO_SAMPLE=OFF \
22                  -DRESTINIO_BENCH=OFF \
23                  -DRESTINIO_FIND_DEPS=ON \
24                  -DRESTINIO_ALLOW_SOBJECTIZER=OFF \
25                  -DRESTINIO_USE_EXTERNAL_HTTP_PARSER=ON \
26                  "
27
28# Header-only library
29RDEPENDS:${PN}-dev = ""
30RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
31