1SUMMARY = "Dibbler DHCPv6 client"
2DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful as well as stateless autoconfiguration for IPv6."
3HOMEPAGE = "http://klub.com.pl/dhcpv6"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3"
7
8SRCREV = "a7c6cf58a88a510cb00841351e75030ce78d36bf"
9
10SRC_URI = "git://github.com/tomaszmrugalski/dibbler \
11           file://dibbler_fix_getSize_crash.patch \
12           "
13PV = "1.0.1+1.0.2RC1+git${SRCREV}"
14
15S = "${WORKDIR}/git"
16
17PACKAGECONFIG ??= "debug bind-reuse resolvconf dns-update"
18
19PACKAGECONFIG[debug] = "--enable-debug,,,"
20PACKAGECONFIG[efence] = "--enable-efence,,,"
21PACKAGECONFIG[bind-reuse] = "--enable-bind-reuse,,,"
22PACKAGECONFIG[dst-addr-filter] = "--enable-dst-addr-check,,,"
23PACKAGECONFIG[resolvconf] = "--enable-resolvconf,,,"
24PACKAGECONFIG[dns-update] = "--enable-dns-update,,,"
25PACKAGECONFIG[auth] = "--enable-auth,,,"
26PACKAGECONFIG[gtest] = "--enable-gtest-static,,,"
27
28inherit autotools
29
30DEPENDS += "flex-native"
31
32LDFLAGS += "-pthread"
33
34PACKAGES =+ "${PN}-requestor ${PN}-client ${PN}-relay ${PN}-server"
35
36FILES:${PN}-client = "${sbindir}/${PN}-client"
37FILES:${PN}-relay = "${sbindir}/${PN}-relay"
38FILES:${PN}-requestor = "${sbindir}/${PN}-requestor"
39FILES:${PN}-server = "${sbindir}/${PN}-server"
40