1SUMMARY = "The dump DAQ test the various inline mode features "
2HOMEPAGE = "http://www.snort.org"
3SECTION = "libs"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f9ce51a65dd738dc1ae631d8b21c40e0"
6
7PARALLEL_MAKE = ""
8
9DEPENDS = "libpcap libpcre libdnet bison-native libnetfilter-queue"
10
11SRC_URI = "http://fossies.org/linux/misc/daq-${PV}.tar.gz \
12           file://disable-run-test-program-while-cross-compiling.patch \
13           file://0001-correct-the-location-of-unistd.h.patch \
14           "
15SRC_URI[sha256sum] = "bdc4e5a24d1ea492c39ee213a63c55466a2e8114b6a9abed609927ae13a7705e"
16# these 2 create undeclared dependency on libdnet and libnetfilter-queue from meta-networking
17# this error from test-dependencies script:
18# daq/daq/latest lost dependency on  libdnet libmnl libnetfilter-queue libnfnetlink
19#
20# never look to /usr/local lib while cross compiling
21
22EXTRA_OECONF = "--enable-nfq-module --disable-ipq-module --includedir=${includedir} \
23    --with-libpcap-includes=${STAGING_INCDIR} --with-dnet-includes=${STAGING_LIBDIR}"
24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
26PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
27
28inherit autotools multilib_script
29MULTILIB_SCRIPTS += "${PN}:${bindir}/daq-modules-config "
30
31DISABLE_STATIC = ""
32
33BBCLASSEXTEND = "native"
34