1DESCRIPTION = "a graphical user interface that allows the user to change print settings"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/OpenPrinting/system-config-printer.git;protocol=https;branch=master"
6
7SRCREV = "895d3dec50c93bfd4f142bac9bfcc13051bf84cb"
8S = "${WORKDIR}/git"
9
10inherit autotools gettext pkgconfig python3native features_check
11
12REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
13
14DEPENDS = "cups glib-2.0 libusb xmlto-native desktop-file-utils-native autoconf-archive-native"
15
16PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
17PACKAGECONFIG[systemd] = ",--without-systemdsystemunitdir,systemd"
18
19do_configure:prepend() {
20    # This file is not provided if fetching from git but required for configure
21    touch ${S}/ChangeLog
22}
23
24do_install:append() {
25    for f in __init__.cpython-311.pyc cupshelpers.cpython-311.pyc \
26        config.cpython-311.pyc ppds.cpython-311.pyc \
27        installdriver.cpython-311.pyc openprinting.cpython-311.pyc \
28        xmldriverprefs.cpython-311.pyc; do
29        rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/cupshelpers/__pycache__/$f
30    done
31}
32
33FILES:${PN} += "${libdir} ${datadir}"
34
35RDEPENDS:${PN} = " \
36    dbus-x11 \
37    gtk+3 \
38    libnotify \
39    python3-core \
40    python3-dbus \
41    python3-firewall \
42    python3-pycups \
43    python3-pycurl \
44    python3-pygobject \
45"
46