1DESCRIPTION = "a graphical user interface that allows the user to change print settings"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/OpenPrinting/system-config-printer.git;protocol=https;branch=master"
6
7SRCREV = "895d3dec50c93bfd4f142bac9bfcc13051bf84cb"
8S = "${WORKDIR}/git"
9
10inherit autotools gettext pkgconfig python3native features_check
11
12REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
13
14DEPENDS = "cups glib-2.0 libusb xmlto-native desktop-file-utils-native autoconf-archive-native python3-setuptools-native"
15
16PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)}"
17PACKAGECONFIG[systemd] = ",--without-systemdsystemunitdir,systemd"
18PACKAGECONFIG[polkit] = ",,,cups-pk-helper"
19
20do_configure:prepend() {
21    # This file is not provided if fetching from git but required for configure
22    touch ${S}/ChangeLog
23}
24
25do_install:append() {
26    cp -rf ${B}/cupshelpers.egg-info ${D}${PYTHON_SITEPACKAGES_DIR}
27    cp -rf ${B}/cupshelpers ${D}${PYTHON_SITEPACKAGES_DIR}
28    rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/*.egg
29    for f in __init__.cpython-311.pyc cupshelpers.cpython-311.pyc \
30        config.cpython-311.pyc ppds.cpython-311.pyc \
31        installdriver.cpython-311.pyc openprinting.cpython-311.pyc \
32        xmldriverprefs.cpython-311.pyc; do
33        rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/cupshelpers/__pycache__/$f
34    done
35}
36
37FILES:${PN} += "${libdir} ${datadir}"
38
39RDEPENDS:${PN} = " \
40    cups \
41    dbus-x11 \
42    gtk+3 \
43    libnotify \
44    python3-core \
45    python3-dbus \
46    python3-firewall \
47    python3-pycups \
48    python3-pycurl \
49    python3-pygobject \
50"
51