1SUMMARY = "This provides screenshot/screencast xdg-desktop-portal backends for wlroots."
2HOMEPAGE = "https://github.com/emersion/xdg-desktop-portal-wlr"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e316e9609dd7672b87ff25b46b2cf3e1"
5
6DEPENDS = " \
7    wayland \
8    wayland-native \
9    wayland-protocols \
10    libdrm \
11    libinih \
12    pipewire \
13    virtual/libgbm \
14"
15
16inherit meson pkgconfig features_check
17REQUIRED_DISTRO_FEATURES = "opengl wayland"
18
19SRC_URI = "git://github.com/emersion/xdg-desktop-portal-wlr.git;protocol=https;nobranch=1 \
20           file://0001-screencast-Fix-build-with-older-mesa.patch"
21
22S = "${WORKDIR}/git"
23SRCREV = "776113a4f014639c29d8de8fcb513493ef7b491f"
24
25PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'basu', d)}"
26
27PACKAGECONFIG[man-pages] = "-Dman-pages=enabled,-Dman-pages=disabled,scdoc-native"
28PACKAGECONFIG[systemd] = "-Dsystemd=enabled -Dsd-bus-provider=libsystemd,-Dsystemd=disabled"
29PACKAGECONFIG[basu] = "-Dsd-bus-provider=basu,,basu"
30
31FILES:${PN} += "${systemd_user_unitdir} ${datadir}"
32