1SUMMARY = "Profiling utilities for GStreamer 1.0 pipelines"
2HOMEPAGE = "https://github.com/kirushyk/gst-instruments"
3SECTION = "multimedia"
4
5LICENSE = "LGPL-3.0-only"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e6a600fd5e1d9cbde2d983680233ad02"
7DEPENDS = "gstreamer1.0"
8SRCREV = "cb8977a6711657e32853159cd539d1d75fcbc772"
9PV = "0.3.1+git${SRCPV}"
10
11SRC_URI = "git://github.com/kirushyk/gst-instruments.git;protocol=https;branch=master"
12
13S = "${WORKDIR}/git"
14
15inherit vala meson pkgconfig
16
17FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*a"
18FILES:${PN} += "${libdir}/*"
19
20INSANE_SKIP:${PN}-dev = "dev-elf"
21
22PACKAGECONFIG ??= "ui"
23PACKAGECONFIG[ui] = "-Dui=enabled,-Dui=disabled,gtk+3"
24