1# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library"
5HOMEPAGE = "https://github.com/graeme-hill/crossguid"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
8DEPENDS += "util-linux"
9
10SRCREV = "ca1bf4b810e2d188d04cb6286f957008ee1b7681"
11SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https;branch=master \
12           file://0001-include-missing-cstdint.patch"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18do_install:append() {
19    sed -i -e 's|${STAGING_DIR_HOST}||g' ${D}${datadir}/crossguid/cmake/crossguid-config.cmake
20}
21