1SUMMARY = "C client library for the Music Player Daemon"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=06b9dfd2f197dc514d8ef06549684b77"
4HOMEPAGE = "https://www.musicpd.org/libs/libmpdclient/"
5
6inherit meson
7
8SRC_URI = " \
9    git://github.com/MusicPlayerDaemon/libmpdclient;branch=master;protocol=https \
10"
11SRCREV = "7124a0ad4841a44db084bb785a6e7120bc8f0139"
12S = "${WORKDIR}/git"
13
14PACKAGECONFIG ??= "tcp"
15PACKAGECONFIG[tcp] = "-Dtcp=true,-Dtcp=false"
16
17do_install:append() {
18    # libmpdclient's Vala bindings are outdated and unmaintained; it
19    # is likely that nobody will ever use them, so let's not install
20    # them
21    rm -rf ${D}${datadir}/vala
22}
23