1SUMMARY = "MusicBrainz client library"
2DESCRIPTION = "The MusicBrainz client is a library which can be built into other programs.  The library allows you to access the data held on the MusicBrainz server."
3HOMEPAGE = "http://musicbrainz.org"
4LICENSE = "LGPL-2.1-or-later"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=fbc093901857fcd118f065f900982c24"
6DEPENDS = "expat libxml2 libxml2-native neon neon-native libmusicbrainz-native"
7
8PV = "5.1.0+git"
9
10SRCREV = "8be45b12a86bc0e46f2f836c8ac88e1e98d82aee"
11SRC_URI = "git://github.com/metabrainz/libmusicbrainz.git;branch=master;protocol=https \
12           file://0001-http-fetch-Pass-a-non-null-buffer-to-ne_set_request_.patch \
13           "
14
15S = "${WORKDIR}/git"
16
17inherit cmake pkgconfig
18
19EXTRA_OECMAKE:append:class-target = " -DIMPORT_EXECUTABLES=${STAGING_LIBDIR_NATIVE}/cmake/${BPN}/ImportExecutables.cmake"
20
21do_install:append:class-native() {
22    install -Dm 0755 ${B}/src/make-c-interface ${D}${bindir}/make-c-interface
23    install -Dm 0644 ${B}/ImportExecutables.cmake ${D}${libdir}/cmake/${BPN}/ImportExecutables.cmake
24    sed -i -e s:'${B}'/src/::g ${D}${libdir}/cmake/${BPN}/ImportExecutables.cmake
25}
26
27BBCLASSEXTEND = "native"
28